What's New

June 12, 2006 - AVR Studio 4.12 SP3: Sw: 0x0100 0x0100

  • Full Support for: ATmega48/88/168, ATmega8, ATmega32, ATmega128, ATtiny13, ATtiny25/45/85 and ATtiny2313


Introduction

Introducing AVR Dragon

'

Front Side Back Side

With the AVR Dragon, Atmel has set a new standard for low cost development tools. AVR Dragon supports all programming modes for the Atmel AVR device family. It also include full emulation support for devices with 32kB or less Flash memory.

At a fraction of the price traditionally associated with this kind of featured tool, the AVR Dragon will fulfill all your programming and emulation needs. The flexible and secure firmware upgrade feature allows AVR Studio to easily upgrade the AVR Dragon to support new devices.

To see which devices are currently supported please read the Device Support page.

(New devices will be added through AVR Studio updates or Service Packs on a regular basis)

Supported Protocols

Currently the following protocols are supported:

Programming Interfaces:

  • In System Programming ( ISP )

  • High Voltage Serial Programming ( HVSP )

  • Parallel Programming ( PP )

  • JTAG Programming ( JTAG Prog)

Emulation Interfaces: (Only available for devices with 32kB Flash or less)

  • JTAG ( JTAG )

  • debugWIRE ( dW )

AVR Dragon can be used with an external target board. However, the onboard prototype area, allow simple programming and debugging without any additional hardware. Please see the Using the AVR Prototype Area section for a description on how to use this.

AVR Dragon is powered by the USB cable, and can also source an external target with up to 300mA (from the VCC connector) when programming or debugging. For more information on technical details, please read the AVR Dragon Requirements section. If the target is already powered by an external power source, the AVR Dragon will adapt and level convert all signals between the target and the AVR Dragon.

Note: It the target board is powered by external power source, no connection should be made betwwen the VCC connector and the external board.

AVR Dragon if fully supported by AVR Studio. This allows the AVR Dragon firmware to be easily updated to support new devices and protocols. When connecting the AVR Dragon, AVR Studio will automatically check the firmware and prompt the user if an updated firmware is available.


Device Support

The following devices are currently supported by AVR Dragon.

 | Programming |  |  |  | Emulation |  |
Device | ISP | HVSP | PP | JTAG | JTAG | dW | Remarks
ATmega48/88/168 | x |  | x |  |  | x |
ATmega8 | x |  | x |  |  |  | ATmega8 does not have on-chip debug function
ATmega32 | x |  | x | x | x |  |
ATmega128 | x |  | x | x |  |  | No emulation support for devices > 32K Flash
ATtiny13 | x | x |  |  |  | x |
ATtiny25/45/85 | x | x |  |  |  | x |
ATtiny2313 | x |  | x |  |  | x |

New devices will be supported through updates of AVR Studio. Please visit www.atmel.com to download the latest version.


Installing Software

Getting Started

Please read this section before connecting the AVR Dragon to the computer or target.

Important !

Please install AVR Studio and the USB driver before connecting AVR Dragon to your PC

Follow these simple steps to get started using the AVR Dragon:

  1. Download AVR Studio 4.12 SP3 or later from http://www.atmel.com/avrdragon

  2. Install AVR Studio and the USB driver

  3. Connect AVR Dragon to the computer, and auto-install new hardware (AVR Dragon) on the computer

  4. Start AVR Studio and the AVR Dragon Programming Dialog

  5. Connect AVR Dragon to the target

USB Setup

In order to use the AVR Dragon it is required to install the AVR Studio and USB driver first. Please do not connect the AVR Dragon to the computer before running the USB Setup in order to follow this procedure described in Software and USB Setup.

Unpacking the AVR Dragon.

The box contains:

  • AVR Dragon tool

  • Internet link to Software ( http://www.atmel.com/avrdragon )

There is no CD shipped with the AVR Dragon. The only way of getting the software is by downloading it directly from the Internet.

You will also need: (not included)

  • PC with free USB connector or a USB HUB capable of delivering 500mA

  • USB Cable

  • AVR Studio 4.12 with Service Pack 3 or later ( Link: http://www.atmel.com/avrdragon )
  • 6/10 pin Header Connector (or similar cables to connect the AVR Dragon to the target board)

System Requirements

The minimum hardware and software requirements are:

  1. Pentium (Pentium II and above is recommended)

  2. Windows® 98, Windows ME, Windows® 2000 or Windows® XP

  3. 64 MB RAM

  4. AVR Studio 4.12 with Service Pack 3

  5. USB port, self-powered (500mA required)

  6. Internet Connection for Software download

Note: Windows 95 and Windows NT does not support USB, hence cannot be used with AVR Dragon


Software_USB_setup

Software and USB Setup

Software and USB Setup

In order to use the AVR Dragon it is required to install the USB driver. Please do not connect the AVR Dragon to the computer before running the USB Setup. USB driver installation is done during the AVR Studio installation.

Note: AVR Dragon requires AVR Studio 4.12 with Service Pack 3 or later. Latest version of the AVR Studio can be found at: www.atmel.com/products/AVR/

Start the AVR Studio installation. During this installation the dialog box in the figure below will be presented to the user.

To install the USB driver, check the Install/Upgrade USB Driver checkbox, and the USB Driver will automatically be installed.

Install new hardware on the computer

When AVR Studio and USB driver installation is finished, please attach the USB cable to both PC and AVR Dragon. (The AVR Dragon is powered from the USB). If it is the first time the AVR Dragon is connected to the computer, the box below will appear:

If running Windows XP you need to click "Next" a couple of times. Please wait until the installation process completes by itself. It may take from a few seconds up to a few minutes depending on the computer and operating system.

If the USB driver is correctly installed and AVR Dragon is connect to the PC, the green LED inside the encasing next to the USB connector will be lit.

If the AVR Studio for some reason can't detect the AVR Dragon after the USB setup, try to restart the computer in order to get the driver properly loaded.

Install USB driver after AVR Studio is installed

The USB driver can be installed even after AVR Studio have been installed by following these steps:

  1. Open "Control Panel" on the PC (Windows 95 and Windows NT does not support USB)

  2. Select "Add or Remove Programs"

  3. Select "AVRStudio4" in the list of programs

  4. Click on the "Change" button

  5. Select "Modify"

  6. Select "Install/upgrade USB Driver"

The USB driver is now properly installed on the PC

Note: The AVR Dragon requires a USB port that can deliver 500mA (self-powered USB hub).


Board Description

AVR Dragon Board:

Headers:

Out of the box, the AVR Dragon has the following 3 header connectors mounted:

  • ISP Header - Used for ISP programming and debugWIRE OCD

  • JTAG Header - Used for JTAG programming and JTAG OCD.

  • VCC Header - Used for powering Devices placed in the prototype area, or to power external target boards (max 300mA)

The following header are not mounted

  • HV_PROG Header

  • EXPAND Header

  • 40-pin DIP socket

  • 28-pin DIP socket

ISP Header (mounted):

This 6-pin header uses the standard AVR ISP pinout for easy connection to external targets. The signals are level-converted to allow communication with targets running at any voltage between 1.8 and 5.5V

JTAG Header(mounted):

The 10-pin JTAG header is a standard pinout JTAG connector. When connecting the AVR Dragon JTAG header to an external target, the signals are level converted to match the target board voltage. This is done automatically. Please note that the AVR Dragon will not power the target through the JTAG interface. The target needs to be powered through a dedicated powersupply. (or by powering it using the VCC connector (5.0V max 300mA)

Pin | Signal | I/O | Description
1 | TCK | Output | Test Clock, clock signal from AVR Dragon to target JTAG port
2 | GND | - | Ground
3 | TDO | Input | Test Data Output, data signal from target JTAG port to AVR Dragon
4 | VTref | Input | Target reference voltage. VDD from target used to control level-converter
5 | TMS | Output | Test Mode Select, mode select signal from AVR Dragon to target JTAG port
6 | nSRST | In/Out-put | Open collector output from adapter to the target system reset. This pin is also an input to the adapter so that the reset initiated on the target may be reported to the AVR Dragon
7 | - | - | Not connected
8 | nTRST | NC (Output) | Not Connected, reserved for compatibility with other equipment (JTAG port reset)
9 | TDI | Output | Test Data Input, data signal from AVR DragoI to target JTAG port
10 | GND | - | Ground

HV_PROG Header (not mounted):

The HV_PROG connector contains all signal required to do HVSP or PP programming. The signals on this connector is not level-converted, and should only be connected to the EXPAND connector on the AVR Dragon. You could damage both your target and the AVR Dragon if you try to do HVSP or PP on an external target board.

VCC Header (mounted):

The VCC Header contains 5.0 Volt VCC and GND that must be used to power the target device placed in the prototype area of the AVR Dragon board. The voltage can also be used to power an external target board, but it is important that the current consumption is less than 300mA. Please note that the AVR Dragon current sourcing capabilities are also limited by the amount of current the Host USB controller can deliver.

EXPAND Header (not mounted):

The expand connector is directly mapped to the 28 and 40-pin DIP sockets. Pin 1 on the connector - is pin one on both the 28 and the 40pin DIP socket. When doing either programming or emulation on-board, the appropriate signals should be routed from the ISP, JTAG, VCC and HV_PROG headers to the correct pins on the EXPAND connector. Please read the "Using the AVR Dragon Prototype Area" section for more information on how to use this function.

Status LEDs

Two LEDs show the status of the AVR Dragon. Check the Troubleshooting Guide to check for solutions if there are any errors.

LED # | Color | Description
2 | Green | Indicates AVR Dragon power
1 | Red | Idle, not connected to AVR Studio
 | Dark | Idle, connected to AVR Studio
 | Green | Data Transfere
 | Yellow | Firmware Upgrade or Initialization


ISP Description

In System Programming

In System Programming is well suited for programming devices soldered onto external target boards. This section explains how to connect the AVR Dragon to ISP program an external target. The ISP lines are equipped with level converters that automatically will level shift the AVR Dragon to the target board voltage.

It is recommended that a 6-pin header connector with 2.54mm (100 MIL) spacing is placed on the target board to allow easy access to the ISP programming interface. The following pinout should be used.

Figure: 6pin Header Connector with 2.54mm (100 MIL) spacing

Note: When connecting the AVR Dragon to the target, connect MISO to MISO pin on the target device, MOSI to MOSI and so on.

Connect the 6pin cable from the AVR Dragon to the external target as shown in these pictures:

debugWIRE OCD interface is also accessed through this ISP header.


HVSP_Description

High Voltage Serial Programming Description

Low pin count AVR devices do not have enough IO pins to support the full Parallel Programming interface. These devices instead use HVSP programming, which is a serial version of the Parallel Programming interface.

Important!

Extreme care should be taken if using HVSP mode to program a AVR device on an external target. The HVSP lines do not have level converters, so it is important that the target board is powered by the AVR Dragon VCC header, and not using another power supply. In addition the AVR Dragon will apply 12V to the reset pin, so it is important that the target board is designed to handle 12V on this line.

To avoid damaging the Target Board, the AVR Dragon or both, it is recommended to only use HVSP mode on devices placed in the 28/40 pin DIP socket on the AVR Prototyp area on the AVR Dragon.

Please see the "Device Connection Sheet" section for information on how to connect AVR Dragon for HVSP programming for the different supported devices.

Figure: Prototype Area


PP_Description

Parallel Programming Description

High pin count AVR devices support the full Parallel Programming (PP) interface. This interface offer high speed programming, and also support programming all fuse and lock bits in the AVR Device.

Important!

Extreme care should be taken if using PP mode to program a AVR device on an external target. The PP lines do not have level converters, so it is important that the target board then is powered by the AVR Dragon VCC header, and not using its own power supply. In addition the AVR Dragon will apply 12V to the reset pin, so it is important that the target board is designed to handle 12V on this line.

To avoid damaging the Target Board, the AVR Dragon or both, it is recommended to only use PP mode on devices placed in the 28/40 pin DIP socket on the AVR Prototyp area on the AVR Dragon.

Please see the "Device Connection Sheet" section for information on how to connect AVR Dragon for PP programming.

Figure: Prototype Area


JTAG Description

JTAG Programming Description

AVR devices with JTAG interface also support programming through this interface. The connection for JTAG programming is the same same as the JTAG debug interface. Please see section "Connecting to target through the JTAG Interface " for information how to connect the AVR Dragon to your external target board.

It is also possible to do JTAG Programming on a device placed on the Prototype Area of the AVR Dragon. Please see the "Device Connection Sheets" for information on how to connect the different AVR devices.


Connecting to target through the JTAG Interface

Connecting to the target through the JTAG Interface

A minimum of 6 wires is required to connect AVR Dragon to the target board. These Signals are TCK, TDO, TDI, TMS, VTref and GND.

Optional line is the nSRST. The nTRST signal is not used, and is reserved for compatibility with other equipment.

nSRST is used to control and monitor the target reset line. This is however not necessary for correct emulation. But if the application code sets the JTD bit in the MCUCSR, the JTAG Interface will be disabled. For the AVR Dragon to reprogram the target AVR, it will need to have control of the Reset Pin.

Note: Vsupply is not connected on the AVR Dragon. Hence the AVR Dragon cannot be powered from the target application.

The following text and descriptions will assume a 6-wire connection between the target and AVR Dragon.

The figure below shows which JTAG lines should be connected to the target AVR to ensure correct operation. To avoid drive contention on the lines it is recommended that series resistors are placed between the JTAG lines and external circuitry. The value of the resistor should be chosen so that the external circuitry and the AVR do not exceed their maximum ratings (i.e. sinks or sources to much current).

Connecting AVR Dragon to Target Board

Connecting AVR Dragon to several devices placed in a JTAG Chain

AVR Dragon support emulation of devices placed in a JTAG Chain. When connecting N devices in a JTAG scan chain all devices should connect to TMS and TCK in parallel. The first device should connects it's TDI to the emulator while the TDO should be wired to TDI of the next device up to device N. The last device should connects it's TDO to the emulator.

Connecting AVR Dragon to STK500

STK500 does not have a dedicated JTAG interface connector. To connect the AVR Dragon to the STK500 board, the JTAG Probe must be strapped to the appropriate JTAG Port Pins of the target device using a squid cable. Check the target device datasheet for the location of the JTAG pins on the appropriate device. Figure below shows an example on how the pins should be connected for an ATmega32 on the STK500. Remember to remove the reset jumper on the STK500 if the reset pin is going to be controlled from the AVR Dragon.

Note: Add-on cards for the STK500 like e.g. STK501/502 may have a dedicated JTAG connector.

Example: Connecting AVR Dragon to STK500 with ATmega32

STK500 JTAG Adapter

The STK500 JTAG Adapter, that comes with the JTAGICE mkII, can be used to simplify the connection to the STK500 for AVR devices with JTAG that mates with socket SCKT3100A3 and SCKT3000D3 on the STK500.

Connecting through ISP

If the JTAGEN fuse (JTAG Enable) in the target device is un-programmed, the JTAG Interface will be disabled. This fuse cannot be programmed through the JTAG Interface and must therefore be programmed through e.g. the ISP Interface. This can be done from the AVR Dragon by using the ISP connector.

Note:

If using this ISP connection from AVR Dragon on a STK500, be sure to de-attach the RESET jumper on the STK500. And connect to the correct ISP header.


Connecting to the target board through the debugWIRE interface

Connecting to target through the debugWIRE Interface

A minimum of 3 wires is required for communication between AVR Dragon and the target board with the debugWIRE interface. These Signals are RESET, VTref and GND.

Important!

This interface uses only 1 pin, (RESET pin) for communication with the target. To enable the debugWIRE interface on an AVR Device, the debugWIRE Enable fuse (DWEN) must be programmed, (DWEN=0). AVR devices with debugWIRE interface are shipped with the DWEN fuse un-programmed from the factory. The debugWIRE interface itself cannot enable this fuse. The DWEN fuse can be programmed through ISP mode, which requires connection to a 6-pin header. For this reason it is recommended to place the full 6-pin ISP connector on your target board to simplify emulation and programming.

NOTE: When the DWEN fuse is set, the ISP Interface normal functionality is disabled. This because the debugWIRE must have control over the RESET pin. When DWEN is set it is no longer possible to use ISP. Use debugWIRE or High Voltage programming to disable the DWEN fuse.

Note

If using this connection from AVR Dragon on a STK500, be sure to de-attach the RESET jumper on the STK500. And connect to the correct ISP header for the actual AVR device, guided by the colour code in the STK500 silk-print.

AVR Dragon debugWIRE connector

Connecting AVR Dragon probe to 6-pins ISP header using a 6-pin cable

When DWEN fuse is programmed, there is only need for GND, VTref and RESET line for using the debugWIRE interface. However to ease the task of changing between ISP mode and debugWIRE mode, it is recommended to do debugWIRE with all six lines connected. The AVR Dragon will automatically tristate all unused ISP pins when running debugWIRE.

Note: Some precautions regarding the RESET line must be taken to ensure proper communication over the debugWIRE interface. If there is a pull-up on the RESET line, this resistor must be larger than 10Kohm, and there should be no capacitive load. The pull-up resistor is not required for debugWIRE functionality. Other logic connected to the RESET line should be removed.

Note

It's not possible to use the debugWIRE Interface if the lockbits on the target AVR are programmed. Always be sure that the lockbits are cleared before programming the DWEN fuse and never set the lockbits while the DWEN fuse is programmed. If both the debugWIRE enable fuse (DWEN) and lockbits are set, one can use High Voltage Programming to do a chip erase, hence clear the lockbits. When the lockbits are cleared the debugWIRE Interface will be re-enabled.

Note

The ISP Interface is only capable of reading fuses, signature and do a chip erase when the DWEN fuse is unprogrammed.


Prototype Area

Using the Onboard Prototype Area

The AVR Dragon has layout for a 40-pin and a 28-pin PDIP socket. The DIP socket pins are connected directly to the 40-pin Header connector. By strapping the ISP, JTAG, HV_PROG and VCC header signals to the 40-pin header connector programming or emulation can be preformed without the need for an external target board.

This section shows how to strap the AVR Dragon for different operation modes. Each supported AVR device has its own Device Connection Sheet containing all information required.

There is a number of ways to utilize the prototype area. If only one device type / programming mode is to be used, the easiest and cheapest way is to just solder wires directly from the HV_PROG, ISP, JTAG and VCC headers to the EXPAND header. Howerver, to make the board more flexible header connectors can be soldered in to allow using cables to be connected without soldering.

Here is a suggestion how to modify the AVR Dragon board to make it flexible and able to use all DIP socket AVR devices.

In this picture one 20-pin header connector, a 40-pin header connector and a 40-pin DIP socket has been soldered onto the AVR Dragon.

To make it even more flexible and allow for narrow DIP packages, a ZIF (Zero Insertion Force) DIP socket has been added in the picture above. Additional sockets can be bought from third party vendors to support MLF/QFN, TQFP, SOIC etc packages. (Link: http://www.atmel.com/products/AVR/thirdparty.asp#adapters )

- And finally the complete setup for debugWIRE and ISP programming of the ATtiny45. For details on how this is connected please have a look at the ATtiny45 Device connection sheet


t13 devicesheet

ATtiny13 Devicesheet

Supported programming modes: ISP, HVSP

Supported emulation modes: debugWIRE

High Voltage Serial Programming

 | VCC |  |
6 | A | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | H | G | 19
18 | F | E | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | D | 3
2 | C | B | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | A | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
5 | B | H | 4
6 | C | nc | 3
7 | D | E | 2
8 | G | F | 1

In System Programming and debugWIRE emulation:

 | VCC |  |
6 | A | nc | 5
4 | G | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | E | F | 5
4 | B | D | 3
2 | A | C | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
5 | B | E | 4
6 | C | nc | 3
7 | D | nc | 2
8 | G | F | 1


t25 devicesheet

Devicesheet: ATtiny25, ATtiny45, ATtiny85

Supported programming modes: ISP, HVSP

Supported emulation modes: debugWIRE

High Voltage Serial Programming

 | VCC |  |
6 | A | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | H | G | 19
18 | F | E | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | D | 3
2 | C | B | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | A | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
5 | B | H | 4
6 | C | nc | 3
7 | D | E | 2
8 | G | F | 1

In System Programming and debugWIRE emulation:

 | VCC |  |
6 | A | nc | 5
4 | G | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | E | F | 5
4 | B | D | 3
2 | A | C | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
5 | B | E | 4
6 | C | nc | 3
7 | D | nc | 2
8 | G | F | 1


t2313 devicesheet

ATtiny2313 Devicesheet

Supported Programming Modes: ISP, Parallel Programming

Supported Emulation Modes: debugWIRE

In System Programming and debugWIRE emulation

 | VCC |  |
6 | B | nc | 5
4 | G | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
11 | nc | F | 10
12 | nc | nc | 9
13 | nc | nc | 8
14 | nc | nc | 7
15 | nc | nc | 6
16 | nc | nc | 5
17 | D | nc | 4
18 | A | nc | 3
19 | C | nc | 2
20 | G | E | 1

Parallel Programming

 | VCC |  |
6 | U | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | T | S | 19
18 | R | Q | 17
16 | nc | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | nc | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | U | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
11 | O | T | 10
12 | A | N | 9
13 | B | M | 8
14 | C | L | 7
15 | D | K | 6
16 | E | Q | 5
17 | F | nc | 4
18 | G | J | 3
19 | H | nc | 2
20 | S | R | 1


m48 devicesheet

Devicesheet: ATmega48, ATmega88, ATmega168

Supported Programming Modes: ISP, Parallel Programming

Supported Emulation modes: debugWIRE

In System Programming and debugWIRE emulation

 | VCC |  |
6 | B | nc | 5
4 | G | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
15 | nc | nc | 14
16 | nc | nc | 13
17 | D | nc | 12
18 | A | nc | 11
19 | C | nc | 10
20 | nc | nc | 9
21 | nc | F | 8
22 | nc | G | 7
23 | nc | nc | 6
24 | nc | nc | 5
25 | nc | nc | 4
26 | nc | nc | 3
27 | nc | nc | 2
28 | nc | E | 1

Parallel Programming

 | VCC |  |
6 | U | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | T | S | 19
18 | R | Q | 17
16 | P | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | I | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | U | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
15 | B | A | 14
16 | C | P | 13
17 | D | O | 12
18 | E | N | 11
19 | F | nc | 10
20 | nc | Q | 9
21 | nc | T | 8
22 | nc | S | 7
23 | G | M | 6
24 | H | L | 5
25 | I | K | 4
26 | nc | J | 3
27 | nc | nc | 2
28 | nc | R | 1

 | VCC |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
21 | nc | nc | 20
22 | nc | nc | 19
23 | nc | nc | 18
24 | nc | nc | 17
25 | nc | nc | 16
26 | nc | nc | 15
27 | nc | nc | 14
28 | nc | nc | 13
29 | nc | nc | 12
30 | nc | nc | 11
31 | nc | nc | 10
32 | nc | nc | 9
33 | nc | nc | 8
34 | nc | nc | 7
35 | nc | nc | 6
36 | nc | nc | 5
37 | nc | nc | 4
38 | nc | nc | 3
39 | nc | nc | 2
40 | nc | nc | 1


m8 devicesheet

Devicesheet: ATmega8

Supported Programming Modes: ISP, Parallel Programming

Supported Emulation modes: debugWIRE

In System Programming and debugWIRE emulation

 | VCC |  |
6 | B | nc | 5
4 | G | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
15 | nc | nc | 14
16 | nc | nc | 13
17 | D | nc | 12
18 | A | nc | 11
19 | C | nc | 10
20 | nc | nc | 9
21 | nc | F | 8
22 | nc | G | 7
23 | nc | nc | 6
24 | nc | nc | 5
25 | nc | nc | 4
26 | nc | nc | 3
27 | nc | nc | 2
28 | nc | E | 1

Parallel Programming

 | VCC |  |
6 | U | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | T | S | 19
18 | R | Q | 17
16 | P | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | I | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | U | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
 | nc | nc |
15 | B | A | 14
16 | C | P | 13
17 | D | O | 12
18 | E | N | 11
19 | F | nc | 10
20 | nc | Q | 9
21 | nc | T | 8
22 | nc | S | 7
23 | G | M | 6
24 | H | L | 5
25 | I | K | 4
26 | nc | J | 3
27 | nc | nc | 2
28 | nc | R | 1


m32 devicesheet

Devicesheet: ATmega32

Supported Programming Modes: ISP, PP, JTAG Prog

Supported Emulation Modes: JTAG

In System Programming

 | VCC |  |
6 | B | nc | 5
4 | G | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
21 | nc | nc | 20
22 | nc | nc | 19
23 | nc | nc | 18
24 | nc | nc | 17
25 | nc | nc | 16
26 | nc | nc | 15
27 | nc | nc | 14
28 | nc | nc | 13
29 | nc | nc | 12
30 | nc | F | 11
31 | nc | G | 10
32 | nc | E | 9
33 | nc | C | 8
34 | nc | A | 7
35 | nc | D | 6
36 | nc | nc | 5
37 | nc | nc | 4
38 | nc | nc | 3
39 | nc | nc | 2
40 | nc | nc | 1

JTAG Programming and JTAG Emulation

 | VCC |  |
6 | D | H | 5
4 | I | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | nc | nc | 19
18 | nc | nc | 17
16 | nc | nc | 15
14 | nc | nc | 13
12 | nc | nc | 11
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1
 | JTAG |  |
10 | H | G | 9
8 | nc | nc | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1

 | DEVICE |  |
21 | nc | nc | 20
22 | nc | nc | 19
23 | nc | nc | 18
24 | A | nc | 17
25 | E | nc | 16
26 | C | nc | 15
27 | G | nc | 14
28 | nc | nc | 13
29 | nc | nc | 12
30 | nc | B | 11
31 | nc | I | 10
32 | nc | F | 9
33 | nc | nc | 8
34 | nc | nc | 7
35 | nc | nc | 6
36 | nc | nc | 5
37 | nc | nc | 4
38 | nc | nc | 3
39 | nc | nc | 2
40 | nc | nc | 1

Parallel Programming

 | VCC |  |
6 | U | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | HV_PROG |  |
20 | T | S | 19
18 | R | Q | 17
16 | P | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | I | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
 | ISP |  |
6 | nc | nc | 5
4 | nc | nc | 3
2 | U | nc | 1
 | JTAG |  |
10 | nc | nc | 9
8 | nc | nc | 7
6 | nc | nc | 5
4 | nc | nc | 3
2 | nc | nc | 1

 | DEVICE |  |
21 | P | O | 20
22 | nc | N | 19
23 | nc | M | 18
24 | nc | L | 17
25 | nc | K | 16
26 | nc | J | 15
27 | nc | nc | 14
28 | nc | Q | 13
29 | nc | nc | 12
30 | nc | T | 11
31 | nc | S | 10
32 | nc | R | 9
33 | nc | H | 8
34 | nc | G | 7
35 | nc | F | 6
36 | nc | E | 5
37 | nc | D | 4
38 | nc | C | 3
39 | nc | B | 2
40 | I | A | 1


m128 devicesheet

Devicesheet: ATmega128

Supported Programming Modes: ISP, PP, JTAG Prog

Supported Emulation Modes: -

Since the ATmega128 is only available in TQFP and MLF/QFN package, it can not directly be used on the AVR Dragon prototype area.


Troubleshooting

Problem | Reason | Solution
Signature Bytes read as 0x00 0x00 0x00 | ISP Frequency is to high. | Lower ISP freq under the board settings
Not able to communicate with device through debugWIRE | RESET pullup resistor to small | Remove or increase the pull-up value to 10K ohm or more.
Not able to communicate with device through debugWIRE | Decoupling Capasitor destroys communication on RESET line | Remove Decoupling capasitor on reset line during debugWIRE emulation
debugWIRE communication fails when using STK500 | RESET line strongly tied to VCC | Remove RESET jumper on STK500 to allow AVR Dragon to control the line.
After successfully enabling the DWEN fuse, AVR Dragon is not able to enter debug mode | RESET line strongly tied to VCC | Remove RESET jumper on STK500 to allow AVR Dragon to control the line.


known issues

No known issues.


Requirements

AVR Dragon Requirements

System Unit

Physical Dimensions...................................... ( H x W x D ) 53 x 105 x 15 mm

Power Voltage Requirements........................... 5.0V USB powered

AVR Dragon Current Consumption................... 100mA

Max Current Source Capability (to target)......... 300mA

Ambient Temperature.......................................0-70'C

Operation

Minimum Programming Speed..........................TBD

Maximum Programming Speed.........................TBD

Minimum Emulation Speed...............................TBD

Maximum Emulation Speed..............................TBD

Target Voltage Range.......................................1.8 - 5.5 V

I/O Pins

Maximum Source Current ISP header................TBD

Maximum Sink Current ISP header....................TBD

Maximum Source Current JTAG header.............TBD

Maximum Sink Current JTAG header.................TBD

Maximum Source Current VCC header...............TBD

Maximum Sink Current VCC header...................TBD


Technical Support

Before requesting techical support make sure you have the latest available AVR Studio, tool firmware installed. The latest AVR Studio version can be downloaded from www.atmel.com/avrstudio, and contains the latest firmware version for all Atmel AVR tools. When connecting your tool, AVR Studio will automatically check the firmware version and request an update if needed.

For technical support please contact avr@atmel.com. When requesting technical support for AVR Dragon please include the following information:

  • Version number of AVR Studio. This can be found in AVR studio menu "Help->About"

  • PC processor type and speed

  • PC operating system and version

  • What target AVR device is used (Complete part number)

  • Fuse settings on the AVR

  • Target clock frequency

  • If CLKPR (Clock Prescaler Register) is used (for AVRs with this feature)

  • Target voltage

  • Programming speed

  • A detailed description of the problem, and how to recreate it.

  • Any error or waring information generated by AVR Studio when the error occurred.


Installing AVR Studio

AVR Studio with its Integrated Development Environment (IDE) is the ideal software for all AVR development. It has an editor, an assembler, and a debugger and is the front-end for all the AVR Tools including the AVR Dragon

To install AVR Studio insert the supplied Atmel Technical Library CD-ROM in the computer and use your browser to navigate. A reference to AVR Studio 4 can be found in the entry form. Install AVR Studio 4 following the instructions on the screen.

  • AVR Studio version 4.12 with Service Pack 3or later is required for JTAGICE mkII support.

The newest release of AVR Studio with support for new devices can be found at www.atmel.com/AVR.

In order to be able to use the USB the driver for the USB needs to be installed. See Gettting Started for descriptions regarding the USB driver installation.