[sdiy] STM32G4 SAI problems

The SynthiMuse synthimuse at gmail.com
Sat Jul 15 23:47:58 CEST 2023


Hi Richie
I'm working on a project with a nucleo G4.
I can try get the i2s working and I'll let you know how I get on. I'll send
the 'ioc' file if I get something working.
Cheers
Gerry



On Sat, 15 Jul 2023, 21:41 , <rburnett at richieburnett.co.uk> wrote:

> Anyone using STM32G4 with STM32CubeIDE and managed to get the SAI codec
> interface working?
>
> I've been banging my head against a brick wall here for the past two
> days trying to configure the SAI peripheral of a Nucleo-G474RE using the
> CubeIDE graphical config tool (MX?), and still no signs of life on the
> relevant pins!  It asks me what "Audio Frequency" I want from a drop
> down menu of the usual suspects (32k, 44.1k, 48k, 96k, etc.) but the
> "Real Audio Frequency" and "Error" both stay stubbornly stuck at zero
> and greyed out.  The clock source shows as "SAI PLL Clock" but is greyed
> out (and can't be changed,) and I've tried all possible options for the
> SAI clock MUX in the actual clock config tool anyway, including an
> external I2S clock input.  Still no luck.
>
> Why does this have to be so difficult!?  And why do chip vendors always
> provide working examples for every peripheral except SAI / I2S ! (>.<)
>
> I have managed to get a LED blinking, and send "Hello World!" to a
> terminal via UART though, so not entirely fruitless.
>
> -Richie,
> _______________________________________________
> Synth-diy mailing list
> Synth-diy at synth-diy.org
> http://synth-diy.org/mailman/listinfo/synth-diy
> Selling or trading? Use marketplace at synth-diy.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://synth-diy.org/pipermail/synth-diy/attachments/20230715/9d50a680/attachment.htm>


More information about the Synth-diy mailing list