[sdiy] Jupiter 8 not booting

Adam Inglis (synthDIY) synthdiy at adambaby.com
Wed Feb 3 08:35:05 CET 2021


Thanks all for the replies. I always find it educational seeing how people think about troubleshooting these things.

Yes I thought TR2 would have to be a likely culprit - but why did it only fail at start up and never during operation once started? 
The only other thing connected that I could trace to the reset line was a gate that selected a RAM chip - must be a start up requirement. 

Before I started cutting traces etc I pulled the board out and measured the ESR of the three electrolytic caps in that little circuit - and lo and behold C7 read high, and C8 was off scale (i.e. more than 99 ohms on my little tester). Removing C8 you could see the corrosion/damage. I replaced all three and the problem does indeed appear to have been fixed!

Many thanks once again - and Brian, thanks for the circuit analysis. I had muddled out a rough idea something along those lines. Now that I think of it, my DX7 has a similar circuit and has given me similar trouble in the past.

cheers
Adam

> On 2 Feb 2021, at 3:39 pm, Brian Willoughby <brianw at audiobanshee.com> wrote:
> 
> I suspect that C7 or C8 is bad (or both). I had a bad capacitor in a TR-808 where touching it would make it work again, but a slight bump and it would stop working. This would explain your intermittent troubles.
> 
> 
> If you had a digital/analog scope with recording abilities, you could look at what happens to the two Base and Collector voltages over time.
> 
> 
> The circuit is a bit surprising. I've never looked at one of these startup Reset timing circuits before, so I never analyzed the time constants.
> 
> Ignoring all but the last stage, I would expect that TR2 could pull the Reset line low (active) rather quickly, because there's little resistance when the transistor is conducting, and that will discharge C9 rather quickly.
> 
> In contrast, when TR2 turns off, the 47 kΩ R4 and 10 uF (16 V) C9 would take 0.47 seconds to charge up to 3.16 V and 2.35 seconds to charge to basically the full 5 V. Of course, it depends upon the logic threshold for the Reset line, because it should trigger before the full 5 V anyway. Maybe the intention is for the system to keep the processor in Reset for a second or two while power stabilizes. This is the only part I find surprising, but maybe it's actually normal.
> 
> None of this explains 5 or 10 minutes, unless R4 is open-circuited. As far as I can tell, R4 brings the CPU out of Reset as soon as TR2 stops conducting.
> 
> 
> Looking at the rest of the circuit, TR2 should conduct in under 1 millisecond after power-up. At some point, TR1 conducts and turns off TR2. I just can't quite figure out what happens to C7 that would control the timing of the Reset pulse. I assume that C7 starts with 0 V across it, then charges up to 4.31 V.
> 
> As I mentioned, the weirdest thing to me is the slow rise time of more than one second. Many modern processors would require a sharper rise time on the Reset line for proper operation.
> 
> 
> I would expect that when not working, TR2 Base would be 0.59 V, not 0.14 V. That's because I assume R4 is good and TR2 is on. If that's not the case, then check R4.
> 
> Brian
> 
> 
> On Feb 1, 2021, at 20:03, Adam Inglis wrote:
>> 
>> Could I trouble some patient soul to cast their eyes over this circuit and explain what should happen?
>> The JP8 CPU reset circuit is in the grey box on the right half of the image.
>> 
>> <JP8 CPU reset.jpeg>
>> 
>> 
>> 
>> My jupe has been taking its time booting these last few months, 5 or 10 minutes, and now sometimes is refusing to boot at all. (Occasionally it will boot as usual in a couple of seconds after going through the tune routine, so the fault appears to be intermittent). 
>> Up on the bench, when failing to boot, I measure the reset pin 26 on the CPU as 1.4 v. When it boots successfully, that voltage takes a second to go from 1.4 up to 4.9 volts.
>> So I’m suspecting something in the reset circuit.
>> 
>> When working:
>> Transistor 1 measures
>> E  = 00 v
>> C = 0.14 v
>> B = 0.59 v
>> Transistor 2 measures
>> E = 00v
>> C = 4.9 v
>> B = 0.14 v
>> 
>> When not working the only change is the collector of TR2 doesn’t come up above 1.4  v
>> 
>> cheers
>> Adam
>> _______________________________________________
>> Synth-diy mailing list
>> Synth-diy at synth-diy.org
>> http://synth-diy.org/mailman/listinfo/synth-diy
>> Selling or trading? Use marketplace at synth-diy.org
> 





More information about the Synth-diy mailing list