[sdiy] Prophet-5 help?

Eric Frampton eric at ericframpton.com
Fri Sep 20 06:21:27 CEST 2019

replies inline

> On Sep 19, 2019, at 2:26 AM, Brian Willoughby <brianw at audiobanshee.com> wrote:
> A) Did the original 2716 EPROMs have v.8.2 firmware? … or a different version?

They were originally 2708’s and had v.8.1 (IIRC - I’m not in front of my notes right now)

> Do you have an EPROM reader/burner so that you can read the data off the old 2716 chips?

Mine won’t read 2708’s, no.

> My point here is that if you weren’t running v.8.2 before, then that might not be the right version for your exact hardware revision. There were four different Rev 3 releases. I’m not familiar with whether they each required different firmware, but it’s not like the machine can tell you that it has incompatible firmware installed - other than when it doesn’t work right.

According to the service docs, some S/N’s shipped with 8.0, and some 8.1, but according to later service docs 8.2 shipped after the fact to resolve an issue where units would spontaneously drop into Edit, so I’m assuming this would work in any earlier units. I may be assuming wrong.

> B) Are you sure that your v.8.2 firmware images are correct? By “correct” I mean that all the data is there and it hasn’t been corrupted somehow.

I have no way to check it, besides verifying checksums with the original files (which do pass compared with the chips).

> I can’t remember which synth it was - maybe the Oberheim Matrix-12 - but I got one set of EPROM data that was flat-out wrong.

Yup - it was the Xpander. There was a dump of the ROMs floating around which was incorrect.

> This is one reason I suggest reading a pair of your original 2716 chips and writing the collected data to a 2732. Repeat the process for the correct number of chips. That way, you will know that you’re running the right firmware even though the EPROM socket is literally wired for a different size. It helps to have a disassembler for the processor in the Prophet and some knowledge of how to confirm that the data is even potentially correct, but I realize that’s a tall order.

That’s way beyond my current experience, unfortunately.

> C) After juggling things with supply and memory, you might need to initialize things before they will work. I remember learning about a set of Prophet firmware chips that are designed to initialize, calibrate, and write default presets into the P-5 battery-backed RAM. This is especially necessary for the older ones like my Rev 2 that don’t even have a cassette interface. You may not have the same issue since you have cassette, but perhaps there is still something that needs to be initialized in the battery-backed preset RAM before saving patches will work.

I’d love to have a copy of the PROG5 EPROM and the 3.0 memory test, but don’t have copies of either one.

> D) When you drop into Cassette Load mode, does it actually restore fully functional presets?’

It does not, but cassette loads being the dodgy things they are, there may be other factors at play.

> E) I haven’t pulled out the schematics to look into the details of your U320 and U323 references. It’s late at night here in Seattle…



> Brian
> On Sep 18, 2019, at 4:18 PM, Eric Frampton <eric at ericframpton.com> wrote:
>> I’m (still) working on this rev 3.0 Prophet-5 (ugh) and have managed to back myself into a corner.
>> I put the Retrolinear replacement PSU in there with their Memory Watchdog controller chiclet; those parts are working fine.
>> I’ve done the 2716 EPROM mod and installed some v.8.2 ROMs.
>> The unit seems to be working correctly except for one major issue: Since doing the 2716 mod and installing the new firmware, now whenever I got to record a patch, the unit doesn’t exit Record mode (also, the LED never extinguishes) and the patch isn’t written. Unfortunately, because the other mods are done, I can’t backtrack to the 2708’s.
>> If I hit Record+Load, the unit *does* seem to drop into Cassette Load mode, so I think the front panel logic is OK.
>> I can see expected changes at both U320 and U323 when I move the back panel Rec Enable switch
>> I can see active data and address lines on all RAM and EPROMs
>> I’ve tried pulling individual RAM IC’s
>> I’ve tried pulling NVRAM IC’s and swapping them with spares
>> I’m not seeing any change on pin 5 (A15) of the CPU, which is one input of the gate whose output is U320:11.
>> Thoughts?
>> e

More information about the Synth-diy mailing list