[sdiy] Tr-808 issue FIXED

el macaco elmacaco at hotmail.com
Wed Jan 2 23:18:43 CET 2019

Greetings all,

So it seems I fixed the issue with the TR-808 .

The issue was it would switch on, light up except the step button and be unresponsive.

Seemed like the muting circuit was keeping the CPU in reset mode.  I replaced the 2SK30’s, the 945 NPN transistor in the circuit, but was waiting for the 733’s PNP transistors.  Found some in a local shop in the jungle where I live, replaced the two in the muting circuit and now it responds!

The problem would come and go, but I got at it while it wasn’t working so I’m hoping it’s solved.

While studying the schematic, I see the signal that goes to one 2SK30 for the cpu interrupt pin ties to one Schmidt trigger which then signals the CPU.  I got a spare hex Schmidt trigger chip to replace the original but since the 733’s seem to fix it I never got that far.  In case anyone has the issue in the future I note it here.

The accent trigger out wasn’t making contact in the 3 on miles connector, fixed that while I was in there too, but I’m not sure if that would cause the issue I had.

Thanks to all for the advice in debugging this and the potential problems to look for in old gear.  I love the learning here.


On Sep 14, 2018, at 10:08 PM, Nathan Trites <nathan at idmclassics.net<mailto:nathan at idmclassics.net>> wrote:

I want to hear what's wrong with the oscilloscope now, too :)


On Fri, Sep 14, 2018 at 5:37 PM, el macaco <elmacaco at hotmail.com<mailto:elmacaco at hotmail.com>> wrote:
So after months of not working I switch it on to test and the motherfucker works fine.  Sheesh.  Even still, I expect it to fail the same way as soon as I put the screws in.

The only transistor in the protection circuit I didn’t replace was the 733 I couldn’t get locally.  Will get some to have it all new.

Also will check sync switch wiring although I did continuity test them and they were fine.

Tony, that sounds possible, the wires to the power switch I’ve had to reattach a few times and I’ve heard that the cable position can wipe some memory locations on power up.

Will check for .6v across those resistors when it fails again.

I will get my scope situation sorted ASAP since I do miss it dearly.  Don’t really want to hike with it for 4 hours to get it serviced in town, which should be possible.  The 808 no one can handle here,  just too rustic, but they repair everything here so they have scopes and rewind transformers etc.

Thanks everyone for all the guidance! I will switch it on everyday to catch it slipping and keep diagnosing or replacing every damned part in the thing.  I have time....

Would like to know tho.  Thanks for clearing the transformer of suspicion, which was what I would have done had I not asked.



On Sep 14, 2018, at 3:06 PM, Richie Burnett <rburnett at richieburnett.co.uk<mailto:rburnett at richieburnett.co.uk>> wrote
>> ...Sometimes switching it on and leaving it on for a while it will come to life with the step led blinking sudddenly.
> One time I got it to live by plugging a Pedal into the start stop jack. Sometimes with the din sync switch but only once or twice.
>> ...It’s been months of sometimes, then I thought I fixed it, it worked reliably for weeks, then when I put all the screws back in it didn’t work.
> Definitely sounds like a loose connection somewhere or a cracked PCB track to me.  If it was due to the UVLO/brown-out circuitry it would either work or not work at a particular supply voltage, not work intermittently.
> As others have said, I think you're either gonna need an oscilloscope, or to hand it over to someone who's got one to find out which signals have gone absent when it is in the non-working state.
> -Richie,

Synth-diy mailing list
Synth-diy at synth-diy.org<mailto:Synth-diy at synth-diy.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://synth-diy.org/pipermail/synth-diy/attachments/20190102/37436466/attachment.htm>

More information about the Synth-diy mailing list