[sdiy] Mixed-signal problems (dsPIC digital delay project)

Ullrich Peter Peter.Ullrich at kapsch.net
Thu Jan 26 17:24:27 CET 2017


Hi Tom!

You forgot to add power decoupling capacitors at each oft he opamps!
This could lead to big problems.

I had a filter circuit (with NE5532) that also missed the caps and I had a big 600kHz swing on the output modulated a little bit by the audio signal...
So I heard the audio signals but with lots of distortion and noise. Adding 100nF ceramic caps near the power supply pins gave me a perfect function.

Ciao
Peter

http://www.ullrich.at.tt

-----Ursprüngliche Nachricht-----
Von: Synth-diy [mailto:synth-diy-bounces at synth-diy.org] Im Auftrag von Tom Wiltshire
Gesendet: Donnerstag, 26. Jänner 2017 16:34
An: synth-diy at synth-diy.org
Betreff: [sdiy] Mixed-signal problems (dsPIC digital delay project)

Hi All,

I'd like some advice. I recently did a PCB for my DigiDelay project:

http://electricdruid.net/diy-digital-delay/

This is a commercial project in as much as I'm selling chips and PCBs. If my asking for help for that bothers you, please stop reading here and accept my apologies.

The pedal is good, but it has more hiss than I'd like. A certain amount is going to be inevitable because the circuit uses the dsPIC's on-chip 12-bit ADC for audio, and the delay processing is only 16-bit. But that's not the problem I'm seeing.

The problem I've got is high frequency noise on the 9V power supply rails. This looks like spikes at the 64KHz sample rate (the audio is sampled every other sample, the interleaved samples are used for the control pots). The spikes are causing an oscillation at around 2.7MHz. This comes out as basic white noise on the audio.

There's an image of the top of the PCB here:

http://electricdruid.net/wp-content/uploads/2016/12/DigiDelayComponentValues.jpg

I thought I'd done as much as I could to reduce interference between the digital and the analog sides of the circuit: The PCB divides the two areas completely (analog on the left, digital on the right), both have separate ground planes. The grounds only meet at a single point back at the power supply input. The dsPIC's analog and digital 3.3V supplies are generated by separate regulators. This is all supposed to help, right?!

It seems to me there must be some simple thing I can do to remove such a high frequency. The audio from the dsPIC is already heavily filtered once it's back in the analog world. This helps (there's less noise after the filters than before them), but it's not eliminating it, I guess since the noise is getting in through the op-amps' power pins.

http://electricdruid.net/wp-content/uploads/2016/10/DigiDelay-Schematic-Pg1.jpg
http://electricdruid.net/wp-content/uploads/2016/10/DigiDelay-Schematic-Pg2.jpg
http://electricdruid.net/wp-content/uploads/2016/10/DigiDelay-Schematic-Pg3.jpg

Any pointers or things I could try would be appreciated.

I'd like to get this properly sorted since I'd like to do a rack version with delay time modulation like the old Ibanex DM2000.

Thanks,
Tom



_______________________________________________
Synth-diy mailing list
Synth-diy at synth-diy.org
http://synth-diy.org/mailman/listinfo/synth-diy



The information contained in this e-mail message is privileged and confidential and is for the exclusive use of the addressee. The person who receives this message and who is not the addressee, one of his employees or an agent entitled to hand it over to the addressee, is informed that he may not use, disclose or reproduce the contents thereof, and is kindly asked to notify the sender and delete the e-mail immediately.




More information about the Synth-diy mailing list