[sdiy] Mixed-signal problems (dsPIC digital delay project)

Jarno Verhoeven jarno.verhoeven at ziggo.nl
Thu Jan 26 16:56:34 CET 2017


    
Hey Tom, did you try leaving off the regulators and hook the circuits up to two lab supplies directly? This might (or might not) eliminate the regulators.Is it there if you just power the analog section?
Regards,Jarno 



Verzonden vanaf mijn Samsung-apparaat

-------- Oorspronkelijk bericht --------
Van: Tom Wiltshire <tom at electricdruid.net> 
Datum: 26-01-2017  16:34  (GMT+01:00) 
Aan: synth-diy at synth-diy.org 
Onderwerp: [sdiy] Mixed-signal problems (dsPIC digital delay project) 

Hi All,

I'd like some advice. I recently did a PCB for my DigiDelay project:

http://electricdruid.net/diy-digital-delay/

This is a commercial project in as much as I'm selling chips and PCBs. If my asking for help for that bothers you, please stop reading here and accept my apologies.

The pedal is good, but it has more hiss than I'd like. A certain amount is going to be inevitable because the circuit uses the dsPIC's on-chip 12-bit ADC for audio, and the delay processing is only 16-bit. But that's not the problem I'm seeing.

The problem I've got is high frequency noise on the 9V power supply rails. This looks like spikes at the 64KHz sample rate (the audio is sampled every other sample, the interleaved samples are used for the control pots). The spikes are causing an oscillation at around 2.7MHz. This comes out as basic white noise on the audio.

There's an image of the top of the PCB here:

http://electricdruid.net/wp-content/uploads/2016/12/DigiDelayComponentValues.jpg

I thought I'd done as much as I could to reduce interference between the digital and the analog sides of the circuit: The PCB divides the two areas completely (analog on the left, digital on the right), both have separate ground planes. The grounds only meet at a single point back at the power supply input. The dsPIC's analog and digital 3.3V supplies are generated by separate regulators. This is all supposed to help, right?!

It seems to me there must be some simple thing I can do to remove such a high frequency. The audio from the dsPIC is already heavily filtered once it's back in the analog world. This helps (there's less noise after the filters than before them), but it's not eliminating it, I guess since the noise is getting in through the op-amps' power pins.

http://electricdruid.net/wp-content/uploads/2016/10/DigiDelay-Schematic-Pg1.jpg
http://electricdruid.net/wp-content/uploads/2016/10/DigiDelay-Schematic-Pg2.jpg
http://electricdruid.net/wp-content/uploads/2016/10/DigiDelay-Schematic-Pg3.jpg

Any pointers or things I could try would be appreciated.

I'd like to get this properly sorted since I'd like to do a rack version with delay time modulation like the old Ibanex DM2000.

Thanks,
Tom



_______________________________________________
Synth-diy mailing list
Synth-diy at synth-diy.org
http://synth-diy.org/mailman/listinfo/synth-diy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://synth-diy.org/pipermail/synth-diy/attachments/20170126/639a4c40/attachment.htm>


More information about the Synth-diy mailing list