F#&*ing EEPROM again???

Tim Ressel Tim_R1 at verifone.com
Tue Mar 21 17:08:44 CET 2000


I suspect a power spike as well, but it would have to happen when the eeprom was
being written to. Another possibility is an ESD event while the eeprom is being
written to. The fun thing about ESD is you can have a significant event (+/-
2KV) and not even feel it. In fact, an ESD event happening NEAR the unit could
be causing the problem.

Any way you slice it, this one going to be tough. For the power supply fix, a
UPS or power conditioner is the way to go. If the internal supply is acting
funny on power up/down, you'll have to get in there with a scope and try to
capture the glitch, then figure a way to fix it. As for the ESD possibility,
there are a few tricks we use around here. The easiest is to tie a low value cap
from the I/O line of the eeprom to ground. Use 100pF or lower. this will capture
fast events and shunt them to ground. Alternately, you can put tiny ferrite
beads on the leads of the eeprom. This has the effect of slowing down the fast
edges of an ESD event, and thus allow the capacitance of the circuit to absorb
the event. More drastic measures like lining the case with metal or conductive
paint should be saved for last. I have seen people use aluminum foil (for
cooking) and spray adhesive to line their cases. Works well, too. 

Good luck!

Tim Ressel--Compliance Engineer
Hewlett-Packard
Verifone Division
916-630-2541  
tim_r1 at verifone.com                     



-----Original Message-----
From: Batz Goodfortune [mailto:batzman at all-electric.com]
Sent: Monday, March 20, 2000 8:44 PM
To: Synth DIY
Subject: F#&*ing EEPROM again???


Y-ellow Y'all.
	I'm desperately out in the wilderness here. This problem beats the hell
out o' me.

The whole system began to fail 2 days ago. Yesterday it just refused to
boot up. Or at least it refused to get past it's initial LED test.
Thinking that the problem was something to do with the front panel, or even
the PSU which is still blowing close to the wind, I pulled the whole thing
apart.

To cut a long story short, after removing and replacing most of the chips
in the system, I removed the EEPROM on a whim. Low and behold the thing
booted. The EEPROM has absolutely nothing to do with the displays or the
rest of the system. It's an I2C EEPROM 24C02 and has only a 2 wire
connection to the micro.

It would appear that as soon as the micro accesses the EEPROM for the first
time, the whole system falls over. Now it has to be said that the whole
system was working just peachy keen for about a month. Then, on the very
day I decide I'm actually going to use it, it stuffs up completely.

Now! I've tried replacing the EEPROM with a new one and there is no change.
I've changed the micro and there is no change. I've tried putting pull-ups
on it and checked for voltages and all that. I can't detect anything out of
the ordinary other than there seems to be no signals passing across the I2C
bus. But this would be expected if the system had fallen in a heap. I
thought there might be spikes or HV leakage with a bad chip and all kinds
of other things but I can't peg it.

I can't think what else to try? It's only 2 wires. I've changed chips. It
was working perfectly up until 2 days ago. And as far as I can tell,
there's been no other change what so ever. I certainly haven't changed any
software or hardware in that time.

Any clues  would be gratefully appreciated.

Be absolutely Icebox.

 _ __        _                              
| "_ \      | |         batzman at all-electric.com
| |_)/  __ _| |_ ____       ALL ELECTRIC KITCHEN               
|  _ \ / _` | __|___ |  Geek music by geeks for geeks
| |_) | (_| | |_  / /   
|_,__/ \__,_|\__|/ /    
                / ,__   http://all-electric.com
Goodfortune    |_____|       



More information about the Synth-diy mailing list