<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=us-ascii" http-equiv=Content-Type>
<META name=GENERATOR content="MSHTML 8.00.6001.23562"></HEAD>
<BODY>
<DIV dir=ltr align=left><SPAN class=476363400-21092021>S<SPAN 
class=476363400-21092021>o, I built the new circuit (I've attached the schematic 
again here).  Note that I changed the 100k resistor from the diode to 
ground to 10k, as this made the simulation results ever so slightly cleaner at 
the transitions.</SPAN></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021></SPAN></SPAN> </DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021>Results: MC14024BCP and CD4024BCN are still clocking as 
they should.  CD4024BE is still clocking on the wrong 
edge.</SPAN></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021></SPAN></SPAN> </DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021>I swapped the diode and the 10k resistor just to see if 
that would have any effect -- it didn't.  Also, I like them the way they 
are because the keep the levels closer to the opamp output and 
zero.</SPAN></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021></SPAN></SPAN> </DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021>I've also attached a scopeshot of the falling edge, 
taken with the probe attached to the 4024 CLOCK pin.  As you 
can see, it is just about the cleanest transition you could ever hope to 
see.  If that edge can't clock a CMOS chip properly, then nothing 
can.</SPAN></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021></SPAN></SPAN> </DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021>So, I'm out of ideas.  I could disconnect the 20k 
resistor to see if the rectifier is affecting the CLOCK pin, but I honestly 
cannot see how it could, given the very low output impedance of the TL072.  
The comparator is more or less completely optimized now, and is performing 
admirably.</SPAN></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021></SPAN></SPAN> </DIV>
<DIV dir=ltr align=left><SPAN class=476363400-21092021><SPAN 
class=476363400-21092021>I guess I'll try Tim's simple clocking circuit on 
breadboard to see if I can get that to work.  However, I'm not holding out 
much hope, since I think it is fair to say that my comparator circuit is 
generating what looks to be a more or less perfect clock 
signal.</SPAN></SPAN></DIV></BODY></HTML>