<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <div class="moz-cite-prefix">On 8/6/2021 8:46 AM, Jean-Pierre
      Desrochers wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:000601d78ada$49b21470$dd163d50$@oricom.ca">
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
      <meta name="Generator" content="Microsoft Word 14 (filtered
        medium)">
      <style>@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
        {mso-style-priority:99;
        mso-style-link:"Texte brut Car";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";
        mso-fareast-language:EN-US;}span.EmailStyle17
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}span.TextebrutCar
        {mso-style-name:"Texte brut Car";
        mso-style-priority:99;
        mso-style-link:"Texte brut";
        font-family:"Calibri","sans-serif";}.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";
        mso-fareast-language:EN-US;}div.WordSection1
        {page:WordSection1;}</style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
      <div class="WordSection1">
        <p class="MsoPlainText"><span lang="EN-CA">I’m doing some tests
            on a rotary encoder and a PIC16F1783.<o:p></o:p></span></p>
        <p class="MsoPlainText"><span lang="EN-CA">A standard Bourns
            encoder like <a
href="https://www.google.ca/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwjyoqDF3JzyAhUmhOAKHf3lAzoQFnoECAoQAw&url=https%3A%2F%2Fwww.bourns.com%2FPDFs%2Fpec11l.pdf&usg=AOvVaw2RyieyzPnujiOTS7LBcbpw"
              moz-do-not-send="true">THIS</a> .<o:p></o:p></span></p>
        <p class="MsoPlainText"><span lang="EN-CA">Connected using 2 x
            10k pullups with 0.01uf caps to ground<o:p></o:p></span></p>
        <p class="MsoPlainText"><span lang="EN-CA">to PORTB of the
            micro. Interrupt calls (falling edges) used on encoder pins
            A & B.<o:p></o:p></span></p>
        <p class="MsoPlainText"><span lang="EN-CA">I struggled so far to
            get clean increments/decrements out of it.<o:p></o:p></span></p>
        <p class="MsoPlainText"><span lang="EN-CA">Many missing counts
            occur..<o:p></o:p></span></p>
        <p class="MsoPlainText"><span lang="EN-CA">I tried many source
            codes on the web with no luck..<o:p></o:p></span></p>
      </div>
    </blockquote>
    <p>If you're missing counts, it could be due to:</p>
    <p>1. Insufficient MCU compute capacity<br>
    </p>
    <p>2. Inefficient or buggy interrupt handler</p>
    <p>3. Excessive switch bounce</p>
    <p>JJS<br>
    </p>
  </body>
</html>